Build #527 for commit d092a034 from master
 failed 3 minutes 48 seconds
gitlab-ci-multi-runner 1.0.4 (014aa8c)
Using Shell executor...
Running on ceph-workbench.dachary.org...
Fetching changes...
Removing .cache/
Removing .coverage
Removing .tox/
Removing ceph_workbench.egg-info/
Removing ceph_workbench/__init__.pyc
Removing ceph_workbench/ceph_qa_suite.pyc
Removing ceph_workbench/delegate.pyc
Removing ceph_workbench/main.pyc
Removing ceph_workbench/util.pyc
Removing ceph_workbench/wbbackport.pyc
Removing ceph_workbench/wbbackportcreateissue.pyc
Removing ceph_workbench/wbbackportsetrelease.pyc
Removing ceph_workbench/wbgit.pyc
Removing ceph_workbench/wbgithub.pyc
Removing ceph_workbench/wbgitlab.pyc
Removing ceph_workbench/wbredmine.pyc
Removing ceph_workbench/wbxref.pyc
Removing tests/__pycache__/
Removing tests/fixture_git.pyc
Removing tests/fixture_github.pyc
Removing tests/fixture_gitlab.pyc
Removing tests/fixture_redmine.pyc
Removing tests/fixture_xref.pyc
Removing virtualenv/
HEAD is now at a281077 version 1.5.17
From http://ceph-workbench.dachary.org/root/ceph-workbench
   a281077..d092a03  master     -> origin/master
Checking out d092a034 as master...
Previous HEAD position was a281077... version 1.5.17
HEAD is now at d092a03... Merge branch 'wip-suse-master' into 'master'
$ bash -x run-tests.sh
+ set -ex
+ trap 'bash tests/teardown.sh' EXIT
+ source bootstrap
++ sudo apt-get install -y software-properties-common
Reading package lists...
Building dependency tree...
Reading state information...
software-properties-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 181 not upgraded.
++ sudo add-apt-repository --yes ppa:git-core/ppa
gpg: keyring `/tmp/tmppu24z33g/secring.gpg' created
gpg: keyring `/tmp/tmppu24z33g/pubring.gpg' created
gpg: requesting key E1DF1F24 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmppu24z33g/trustdb.gpg: trustdb created
gpg: key E1DF1F24: public key "Launchpad PPA for Ubuntu Git Maintainers" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
++ sudo apt-get update
Hit http://security.ubuntu.com trusty-security InRelease
Hit http://ppa.launchpad.net trusty InRelease
Ign http://nova.clouds.archive.ubuntu.com trusty InRelease
Get:1 http://nova.clouds.archive.ubuntu.com trusty-updates InRelease [65.9 kB]
Hit http://security.ubuntu.com trusty-security/main Sources
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://nova.clouds.archive.ubuntu.com trusty Release.gpg
Hit http://security.ubuntu.com trusty-security/universe Sources
Hit http://ppa.launchpad.net trusty/main Translation-en
Get:2 http://nova.clouds.archive.ubuntu.com trusty-updates/main Sources [391 kB]
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Hit https://apt.dockerproject.org ubuntu-trusty InRelease
Get:3 http://nova.clouds.archive.ubuntu.com trusty-updates/universe Sources [173 kB]
Get:4 http://nova.clouds.archive.ubuntu.com trusty-updates/main amd64 Packages [947 kB]
Hit https://apt.dockerproject.org ubuntu-trusty/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/main Translation-en
Get:5 https://apt.dockerproject.org ubuntu-trusty/main Translation-en_US
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Get:6 http://nova.clouds.archive.ubuntu.com trusty-updates/universe amd64 Packages [398 kB]
Get:7 http://nova.clouds.archive.ubuntu.com trusty-updates/main Translation-en [467 kB]
Get:8 http://nova.clouds.archive.ubuntu.com trusty-updates/universe Translation-en [211 kB]
Hit https://packages.gitlab.com trusty InRelease
Hit http://nova.clouds.archive.ubuntu.com trusty Release
Hit http://nova.clouds.archive.ubuntu.com trusty/main Sources
Hit http://nova.clouds.archive.ubuntu.com trusty/universe Sources
Hit https://packages.gitlab.com trusty/main Sources
Hit http://nova.clouds.archive.ubuntu.com trusty/main amd64 Packages
Ign https://apt.dockerproject.org ubuntu-trusty/main Translation-en_US
Hit http://nova.clouds.archive.ubuntu.com trusty/universe amd64 Packages
Hit https://packages.gitlab.com trusty/main amd64 Packages
Ign https://apt.dockerproject.org ubuntu-trusty/main Translation-en
Get:9 https://packages.gitlab.com trusty/main Translation-en_US
Hit http://nova.clouds.archive.ubuntu.com trusty/main Translation-en
Hit http://nova.clouds.archive.ubuntu.com trusty/universe Translation-en
Ign https://packages.gitlab.com trusty/main Translation-en_US
Ign https://packages.gitlab.com trusty/main Translation-en
Ign http://nova.clouds.archive.ubuntu.com trusty/main Translation-en_US
Ign http://nova.clouds.archive.ubuntu.com trusty/universe Translation-en_US
Fetched 2,652 kB in 4s (586 kB/s)
Reading package lists...
++ sudo apt-get install -y git
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 181 not upgraded.
++ git submodule sync
Synchronizing submodule url for 'teuthology'
++ git submodule update --force --init --recursive
Submodule path 'teuthology': checked out '96f40aad706417391b12c96fc4252c9e317a0e58'
++ cd teuthology
++ git clean -ffqdx
++ ./bootstrap install
New python executable in virtualenv/bin/python
Installing setuptools, pip...done.
Downloading/unpacking pip from https://pypi.python.org/packages/b6/ac/7015eb97dc749283ffdec1c3a88ddb8ae03b8fad0f0e611408f196358da3/pip-9.0.1-py2.py3-none-any.whl#md5=297dbd16ef53bcef0447d245815f5144
Installing collected packages: pip
  Found existing installation: pip 1.5.4
    Uninstalling pip:
      Successfully uninstalled pip
Successfully installed pip
Cleaning up...
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Collecting setuptools
  Downloading setuptools-34.2.0-py2.py3-none-any.whl (389kB)
Collecting packaging>=16.8 (from setuptools)
  Using cached packaging-16.8-py2.py3-none-any.whl
Collecting appdirs>=1.4.0 (from setuptools)
  Using cached appdirs-1.4.0-py2.py3-none-any.whl
Collecting six>=1.6.0 (from setuptools)
  Using cached six-1.10.0-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools)
  Using cached pyparsing-2.1.10-py2.py3-none-any.whl
Installing collected packages: six, pyparsing, packaging, appdirs, setuptools
  Found existing installation: setuptools 2.2
    Uninstalling setuptools-2.2:
      Successfully uninstalled setuptools-2.2
Successfully installed appdirs-1.4.0 packaging-16.8 pyparsing-2.1.10 setuptools-34.2.0 six-1.10.0
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Obtaining file:///home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology (from -r requirements.txt (line 3))
Collecting boto==2.39.0 (from -r requirements.txt (line 5))
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached boto-2.39.0-py2.py3-none-any.whl
Collecting cffi==1.5.2 (from -r requirements.txt (line 6))
Collecting cliff==2.2.0 (from -r requirements.txt (line 7))
  Using cached cliff-2.2.0-py2-none-any.whl
Collecting keystoneauth1==2.12.1 (from -r requirements.txt (line 8))
  Using cached keystoneauth1-2.12.1-py2.py3-none-any.whl
Collecting openstacksdk==0.9.5 (from -r requirements.txt (line 9))
  Using cached openstacksdk-0.9.5-py2.py3-none-any.whl
Collecting os-client-config==1.21.1 (from -r requirements.txt (line 10))
  Using cached os_client_config-1.21.1-py2.py3-none-any.whl
Collecting osc-lib==1.1.0 (from -r requirements.txt (line 11))
  Using cached osc_lib-1.1.0-py2-none-any.whl
Collecting oslo.config==3.17.0 (from -r requirements.txt (line 12))
  Using cached oslo.config-3.17.0-py2.py3-none-any.whl
Collecting oslo.i18n==3.9.0 (from -r requirements.txt (line 13))
  Using cached oslo.i18n-3.9.0-py2.py3-none-any.whl
Collecting oslo.serialization==2.13.0 (from -r requirements.txt (line 14))
  Using cached oslo.serialization-2.13.0-py2.py3-none-any.whl
Collecting oslo.utils==3.16.0 (from -r requirements.txt (line 15))
  Using cached oslo.utils-3.16.0-py2.py3-none-any.whl
Collecting python-cinderclient==1.9.0 (from -r requirements.txt (line 16))
  Using cached python_cinderclient-1.9.0-py2.py3-none-any.whl
Collecting python-glanceclient==2.5.0 (from -r requirements.txt (line 17))
  Using cached python_glanceclient-2.5.0-py2.py3-none-any.whl
Collecting python-keystoneclient==3.5.0 (from -r requirements.txt (line 18))
  Using cached python_keystoneclient-3.5.0-py2.py3-none-any.whl
Collecting python-neutronclient==4.1.1 (from -r requirements.txt (line 19))
  Using cached python_neutronclient-4.1.1-py2.py3-none-any.whl
Collecting python-novaclient==6.0.0 (from -r requirements.txt (line 20))
  Using cached python_novaclient-6.0.0-py2.py3-none-any.whl
Collecting python-openstackclient==3.2.0 (from -r requirements.txt (line 21))
  Using cached python_openstackclient-3.2.0-py2.py3-none-any.whl
Requirement already up-to-date: setuptools in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting gevent (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached gevent-1.2.1-cp27-cp27mu-manylinux1_x86_64.whl
Collecting MySQL-python==1.2.3 (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting PyYAML (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting argparse>=1.2.1 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached argparse-1.4.0-py2.py3-none-any.whl
Collecting beanstalkc>=0.2.0 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached beanstalkc-0.4.0-py27-none-any.whl
Collecting bunch>=1.0.0 (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting configobj (from teuthology==1.0.0->-r requirements.txt (line 3))
Requirement already up-to-date: six>=1.9 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting httplib2 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached httplib2-0.10.3.tar.gz
Collecting paramiko>=1.15.1 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached paramiko-2.1.1-py2.py3-none-any.whl
Collecting pexpect (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached pexpect-4.2.1-py2.py3-none-any.whl
Collecting requests (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached requests-2.13.0-py2.py3-none-any.whl
Collecting raven (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached raven-5.32.0-py2.py3-none-any.whl
Collecting web.py (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached web.py-0.38.tar.gz
Collecting docopt (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting psutil>=2.1.0 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached psutil-5.1.3.tar.gz
Collecting configparser (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached configparser-3.5.0.tar.gz
Collecting pytest (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached pytest-3.0.6-py2.py3-none-any.whl
Collecting pytest-capturelog (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting mock (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached mock-2.0.0-py2.py3-none-any.whl
Collecting fudge (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached fudge-1.1.0.tar.gz
Collecting ansible>=2.0 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached ansible-2.2.1.0.tar.gz
Collecting pyopenssl>=0.13 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached pyOpenSSL-16.2.0-py2.py3-none-any.whl
Collecting ndg-httpsclient (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached ndg_httpsclient-0.4.2.tar.gz
Collecting pyasn1 (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached pyasn1-0.2.2-py2.py3-none-any.whl
Collecting prettytable (from teuthology==1.0.0->-r requirements.txt (line 3))
Collecting python-dateutil (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached python_dateutil-2.6.0-py2.py3-none-any.whl
Collecting manhole (from teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached manhole-1.3.0-py2.py3-none-any.whl
Collecting pycparser (from cffi==1.5.2->-r requirements.txt (line 6))
  Using cached pycparser-2.17.tar.gz
Collecting pbr>=1.6 (from cliff==2.2.0->-r requirements.txt (line 7))
  Using cached pbr-1.10.0-py2.py3-none-any.whl
Collecting unicodecsv>=0.8.0; python_version < "3.0" (from cliff==2.2.0->-r requirements.txt (line 7))
Collecting cmd2>=0.6.7 (from cliff==2.2.0->-r requirements.txt (line 7))
  Using cached cmd2-0.6.9.tar.gz
Requirement already up-to-date: pyparsing>=2.0.1 in ./virtualenv/lib/python2.7/site-packages (from cliff==2.2.0->-r requirements.txt (line 7))
Collecting stevedore>=1.16.0 (from cliff==2.2.0->-r requirements.txt (line 7))
  Using cached stevedore-1.20.0-py2.py3-none-any.whl
Collecting iso8601>=0.1.11 (from keystoneauth1==2.12.1->-r requirements.txt (line 8))
  Using cached iso8601-0.1.11-py2.py3-none-any.whl
Collecting positional>=1.0.1 (from keystoneauth1==2.12.1->-r requirements.txt (line 8))
Collecting requestsexceptions>=1.1.1 (from os-client-config==1.21.1->-r requirements.txt (line 10))
  Using cached requestsexceptions-1.1.3-py2.py3-none-any.whl
Requirement already up-to-date: appdirs>=1.3.0 in ./virtualenv/lib/python2.7/site-packages (from os-client-config==1.21.1->-r requirements.txt (line 10))
Collecting Babel>=2.3.4 (from osc-lib==1.1.0->-r requirements.txt (line 11))
  Using cached Babel-2.3.4-py2.py3-none-any.whl
Collecting simplejson>=2.2.0 (from osc-lib==1.1.0->-r requirements.txt (line 11))
  Using cached simplejson-3.10.0.tar.gz
Collecting rfc3986>=0.2.0 (from oslo.config==3.17.0->-r requirements.txt (line 12))
  Using cached rfc3986-0.4.1-py2.py3-none-any.whl
Collecting debtcollector>=1.2.0 (from oslo.config==3.17.0->-r requirements.txt (line 12))
  Using cached debtcollector-1.11.0-py2.py3-none-any.whl
Collecting netaddr!=0.7.16,>=0.7.12 (from oslo.config==3.17.0->-r requirements.txt (line 12))
  Using cached netaddr-0.7.19-py2.py3-none-any.whl
Collecting msgpack-python>=0.4.0 (from oslo.serialization==2.13.0->-r requirements.txt (line 14))
Collecting pytz>=2013.6 (from oslo.serialization==2.13.0->-r requirements.txt (line 14))
  Using cached pytz-2016.10-py2.py3-none-any.whl
Collecting funcsigs>=0.4; python_version == "2.7" or python_version == "2.6" (from oslo.utils==3.16.0->-r requirements.txt (line 15))
  Using cached funcsigs-1.0.2-py2.py3-none-any.whl
Collecting monotonic>=0.6 (from oslo.utils==3.16.0->-r requirements.txt (line 15))
  Using cached monotonic-1.2-py2.py3-none-any.whl
Collecting netifaces>=0.10.4 (from oslo.utils==3.16.0->-r requirements.txt (line 15))
Collecting warlock!=1.3.0,<2,>=1.0.1 (from python-glanceclient==2.5.0->-r requirements.txt (line 17))
Requirement already up-to-date: packaging>=16.8 in ./virtualenv/lib/python2.7/site-packages (from setuptools->teuthology==1.0.0->-r requirements.txt (line 3))
Collecting greenlet>=0.4.10 (from gevent->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached greenlet-0.4.12-cp27-cp27mu-manylinux1_x86_64.whl
Collecting cryptography>=1.1 (from paramiko>=1.15.1->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached cryptography-1.7.2.tar.gz
Collecting ptyprocess>=0.5 (from pexpect->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached ptyprocess-0.5.1-py2.py3-none-any.whl
Collecting contextlib2 (from raven->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached contextlib2-0.5.4-py2.py3-none-any.whl
Collecting py>=1.4.29 (from pytest->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached py-1.4.32-py2.py3-none-any.whl
Collecting jinja2<2.9 (from ansible>=2.0->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached Jinja2-2.8.1-py2.py3-none-any.whl
Collecting pycrypto>=2.6 (from ansible>=2.0->teuthology==1.0.0->-r requirements.txt (line 3))
Collecting wrapt (from positional>=1.0.1->keystoneauth1==2.12.1->-r requirements.txt (line 8))
Collecting jsonschema<3,>=0.7 (from warlock!=1.3.0,<2,>=1.0.1->python-glanceclient==2.5.0->-r requirements.txt (line 17))
  Using cached jsonschema-2.6.0-py2.py3-none-any.whl
Collecting jsonpatch<2,>=0.10 (from warlock!=1.3.0,<2,>=1.0.1->python-glanceclient==2.5.0->-r requirements.txt (line 17))
  Using cached jsonpatch-1.15-py2.py3-none-any.whl
Collecting idna>=2.0 (from cryptography>=1.1->paramiko>=1.15.1->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached idna-2.2-py2.py3-none-any.whl
Collecting enum34 (from cryptography>=1.1->paramiko>=1.15.1->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached enum34-1.1.6-py2-none-any.whl
Collecting ipaddress (from cryptography>=1.1->paramiko>=1.15.1->teuthology==1.0.0->-r requirements.txt (line 3))
  Using cached ipaddress-1.0.18-py2-none-any.whl
Collecting MarkupSafe (from jinja2<2.9->ansible>=2.0->teuthology==1.0.0->-r requirements.txt (line 3))
Collecting functools32; python_version == "2.7" (from jsonschema<3,>=0.7->warlock!=1.3.0,<2,>=1.0.1->python-glanceclient==2.5.0->-r requirements.txt (line 17))
Collecting jsonpointer>=1.9 (from jsonpatch<2,>=0.10->warlock!=1.3.0,<2,>=1.0.1->python-glanceclient==2.5.0->-r requirements.txt (line 17))
  Using cached jsonpointer-1.10-py2-none-any.whl
Installing collected packages: boto, pycparser, cffi, prettytable, pbr, unicodecsv, cmd2, PyYAML, stevedore, cliff, requests, iso8601, wrapt, positional, keystoneauth1, requestsexceptions, os-client-config, openstacksdk, funcsigs, pytz, Babel, oslo.i18n, monotonic, netifaces, debtcollector, netaddr, oslo.utils, simplejson, osc-lib, rfc3986, oslo.config, msgpack-python, oslo.serialization, python-cinderclient, python-keystoneclient, functools32, jsonschema, jsonpointer, jsonpatch, warlock, python-glanceclient, python-neutronclient, python-novaclient, python-openstackclient, greenlet, gevent, MySQL-python, argparse, beanstalkc, bunch, configobj, httplib2, idna, pyasn1, enum34, ipaddress, cryptography, paramiko, ptyprocess, pexpect, contextlib2, raven, web.py, docopt, psutil, configparser, py, pytest, pytest-capturelog, mock, fudge, MarkupSafe, jinja2, pycrypto, ansible, pyopenssl, ndg-httpsclient, python-dateutil, manhole, teuthology
  Running setup.py install for pycparser: started
    Running setup.py install for pycparser: finished with status 'done'
  Running setup.py install for cmd2: started
    Running setup.py install for cmd2: finished with status 'done'
  Running setup.py install for simplejson: started
    Running setup.py install for simplejson: finished with status 'done'
  Found existing installation: argparse 1.2.1
    Not uninstalling argparse at /usr/lib/python2.7, outside environment /home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology/virtualenv
  Running setup.py install for httplib2: started
    Running setup.py install for httplib2: finished with status 'done'
  Running setup.py install for cryptography: started
    Running setup.py install for cryptography: finished with status 'done'
  Running setup.py install for web.py: started
    Running setup.py install for web.py: finished with status 'done'
  Running setup.py install for psutil: started
    Running setup.py install for psutil: finished with status 'done'
  Running setup.py install for configparser: started
    Running setup.py install for configparser: finished with status 'done'
  Running setup.py install for fudge: started
    Running setup.py install for fudge: finished with status 'done'
  Running setup.py install for ansible: started
    Running setup.py install for ansible: finished with status 'done'
  Running setup.py install for ndg-httpsclient: started
    Running setup.py install for ndg-httpsclient: finished with status 'done'
  Running setup.py develop for teuthology
Successfully installed Babel-2.3.4 MarkupSafe-0.23 MySQL-python-1.2.3 PyYAML-3.12 ansible-2.2.1.0 argparse-1.4.0 beanstalkc-0.4.0 boto-2.39.0 bunch-1.0.1 cffi-1.5.2 cliff-2.2.0 cmd2-0.6.9 configobj-5.0.6 configparser-3.5.0 contextlib2-0.5.4 cryptography-1.7.2 debtcollector-1.11.0 docopt-0.6.2 enum34-1.1.6 fudge-1.1.0 funcsigs-1.0.2 functools32-3.2.3.post2 gevent-1.2.1 greenlet-0.4.12 httplib2-0.10.3 idna-2.2 ipaddress-1.0.18 iso8601-0.1.11 jinja2-2.8.1 jsonpatch-1.15 jsonpointer-1.10 jsonschema-2.6.0 keystoneauth1-2.12.1 manhole-1.3.0 mock-2.0.0 monotonic-1.2 msgpack-python-0.4.8 ndg-httpsclient-0.4.2 netaddr-0.7.19 netifaces-0.10.5 openstacksdk-0.9.5 os-client-config-1.21.1 osc-lib-1.1.0 oslo.config-3.17.0 oslo.i18n-3.9.0 oslo.serialization-2.13.0 oslo.utils-3.16.0 paramiko-2.1.1 pbr-1.10.0 pexpect-4.2.1 positional-1.1.1 prettytable-0.7.2 psutil-5.1.3 ptyprocess-0.5.1 py-1.4.32 pyasn1-0.2.2 pycparser-2.17 pycrypto-2.6.1 pyopenssl-16.2.0 pytest-3.0.6 pytest-capturelog-0.7 python-cinderclient-1.9.0 python-dateutil-2.6.0 python-glanceclient-2.5.0 python-keystoneclient-3.5.0 python-neutronclient-4.1.1 python-novaclient-6.0.0 python-openstackclient-3.2.0 pytz-2016.10 raven-5.32.0 requests-2.13.0 requestsexceptions-1.1.3 rfc3986-0.4.1 simplejson-3.10.0 stevedore-1.20.0 teuthology unicodecsv-0.14.1 warlock-1.2.0 web.py-0.38 wrapt-1.10.8
++ rm -fr virtualenv .tox
++ virtualenv virtualenv
New python executable in virtualenv/bin/python
Installing setuptools, pip...done.
++ source virtualenv/bin/activate
+++ deactivate nondestructive
+++ unset pydoc
+++ '[' -n '' ']'
+++ '[' -n '' ']'
+++ '[' -n /bin/bash -o -n '' ']'
+++ hash -r
+++ '[' -n '' ']'
+++ unset VIRTUAL_ENV
+++ '[' '!' nondestructive = nondestructive ']'
+++ VIRTUAL_ENV=/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv
+++ export VIRTUAL_ENV
+++ _OLD_VIRTUAL_PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
+++ PATH=/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
+++ export PATH
+++ '[' -n '' ']'
+++ '[' -z '' ']'
+++ _OLD_VIRTUAL_PS1=
+++ '[' x '!=' x ']'
++++ basename /home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv
+++ '[' virtualenv = __ ']'
++++ basename /home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv
+++ PS1='(virtualenv)'
+++ export PS1
+++ alias 'pydoc=python -m pydoc'
+++ '[' -n /bin/bash -o -n '' ']'
+++ hash -r
++ pip install --upgrade pip
Downloading/unpacking pip from https://pypi.python.org/packages/b6/ac/7015eb97dc749283ffdec1c3a88ddb8ae03b8fad0f0e611408f196358da3/pip-9.0.1-py2.py3-none-any.whl#md5=297dbd16ef53bcef0447d245815f5144
Installing collected packages: pip
  Found existing installation: pip 1.5.4
    Uninstalling pip:
      Successfully uninstalled pip
Successfully installed pip
Cleaning up...
++ pip install --upgrade setuptools
Collecting setuptools
  Using cached setuptools-34.2.0-py2.py3-none-any.whl
Collecting packaging>=16.8 (from setuptools)
  Using cached packaging-16.8-py2.py3-none-any.whl
Collecting appdirs>=1.4.0 (from setuptools)
  Using cached appdirs-1.4.0-py2.py3-none-any.whl
Collecting six>=1.6.0 (from setuptools)
  Using cached six-1.10.0-py2.py3-none-any.whl
Collecting pyparsing (from packaging>=16.8->setuptools)
  Using cached pyparsing-2.1.10-py2.py3-none-any.whl
Installing collected packages: six, pyparsing, packaging, appdirs, setuptools
  Found existing installation: setuptools 2.2
    Uninstalling setuptools-2.2:
      Successfully uninstalled setuptools-2.2
Successfully installed appdirs-1.4.0 packaging-16.8 pyparsing-2.1.10 setuptools-34.2.0 six-1.10.0
++ pip install -r requirements.txt
Collecting alabaster==0.7.7 (from -r requirements.txt (line 2))
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Using cached alabaster-0.7.7-py2.py3-none-any.whl
Collecting ansible==2.1.1.0 (from -r requirements.txt (line 3))
Requirement already satisfied: appdirs==1.4.0 in ./virtualenv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Collecting Babel==2.3.4 (from -r requirements.txt (line 5))
  Using cached Babel-2.3.4-py2.py3-none-any.whl
Collecting beanstalkc==0.4.0 (from -r requirements.txt (line 6))
  Using cached beanstalkc-0.4.0-py27-none-any.whl
Collecting boto==2.39.0 (from -r requirements.txt (line 7))
  Using cached boto-2.39.0-py2.py3-none-any.whl
Collecting bunch==1.0.1 (from -r requirements.txt (line 8))
Collecting cffi==1.5.2 (from -r requirements.txt (line 9))
Collecting cliff==2.2.0 (from -r requirements.txt (line 10))
  Using cached cliff-2.2.0-py2-none-any.whl
Collecting cmd2==0.6.8 (from -r requirements.txt (line 11))
Collecting configobj==5.0.6 (from -r requirements.txt (line 12))
Collecting configparser==3.3.0.post2 (from -r requirements.txt (line 13))
Collecting contextlib2==0.5.1 (from -r requirements.txt (line 14))
Collecting coverage==4.0.3 (from -r requirements.txt (line 15))
Collecting cryptography==1.3 (from -r requirements.txt (line 16))
Collecting d2to1==0.2.12.post1 (from -r requirements.txt (line 17))
Collecting debtcollector==1.8.0 (from -r requirements.txt (line 18))
  Using cached debtcollector-1.8.0-py2.py3-none-any.whl
Collecting discover==0.4.0 (from -r requirements.txt (line 19))
Collecting docopt==0.6.2 (from -r requirements.txt (line 20))
Collecting docutils==0.12 (from -r requirements.txt (line 21))
Collecting ecdsa==0.13 (from -r requirements.txt (line 22))
  Using cached ecdsa-0.13-py2.py3-none-any.whl
Collecting enum34==1.1.2 (from -r requirements.txt (line 23))
Collecting extras==0.0.3 (from -r requirements.txt (line 24))
Collecting fixtures==1.4.0 (from -r requirements.txt (line 25))
  Using cached fixtures-1.4.0-py2.py3-none-any.whl
Collecting flake8==2.2.4 (from -r requirements.txt (line 26))
Collecting funcsigs==1.0.2 (from -r requirements.txt (line 27))
  Using cached funcsigs-1.0.2-py2.py3-none-any.whl
Collecting functools32==3.2.3.post2 (from -r requirements.txt (line 28))
Collecting gevent==1.0.2 (from -r requirements.txt (line 29))
Collecting gitdb==0.6.4 (from -r requirements.txt (line 30))
Collecting github2gitlab==1.5.5 (from -r requirements.txt (line 31))
Collecting githubpy==1.1.0 (from -r requirements.txt (line 32))
Collecting GitPython==1.0.2 (from -r requirements.txt (line 33))
Collecting greenlet==0.4.9 (from -r requirements.txt (line 34))
Collecting hacking==0.10.2 (from -r requirements.txt (line 35))
  Using cached hacking-0.10.2-py2.py3-none-any.whl
Collecting httplib2==0.9.2 (from -r requirements.txt (line 36))
Collecting idna==2.0 (from -r requirements.txt (line 37))
  Using cached idna-2.0-py2.py3-none-any.whl
Collecting ipaddress==1.0.16 (from -r requirements.txt (line 38))
  Using cached ipaddress-1.0.16-py27-none-any.whl
Collecting iso8601==0.1.11 (from -r requirements.txt (line 39))
  Using cached iso8601-0.1.11-py2.py3-none-any.whl
Collecting Jinja2==2.8 (from -r requirements.txt (line 40))
  Using cached Jinja2-2.8-py2.py3-none-any.whl
Collecting jsonpatch==1.14 (from -r requirements.txt (line 41))
  Using cached jsonpatch-1.14-py2.py3-none-any.whl
Collecting jsonpointer==1.10 (from -r requirements.txt (line 42))
  Using cached jsonpointer-1.10-py2-none-any.whl
Collecting jsonschema==2.5.1 (from -r requirements.txt (line 43))
  Using cached jsonschema-2.5.1-py2.py3-none-any.whl
Collecting keystoneauth1==2.12.1 (from -r requirements.txt (line 44))
  Using cached keystoneauth1-2.12.1-py2.py3-none-any.whl
Collecting linecache2==1.0.0 (from -r requirements.txt (line 45))
  Using cached linecache2-1.0.0-py2.py3-none-any.whl
Collecting MarkupSafe==0.23 (from -r requirements.txt (line 46))
Collecting mccabe==0.2.1 (from -r requirements.txt (line 47))
Collecting mock==1.3.0 (from -r requirements.txt (line 48))
  Using cached mock-1.3.0-py2.py3-none-any.whl
Collecting monotonic==1.2 (from -r requirements.txt (line 49))
  Using cached monotonic-1.2-py2.py3-none-any.whl
Collecting msgpack-python==0.4.8 (from -r requirements.txt (line 50))
Collecting MySQL-python==1.2.3 (from -r requirements.txt (line 51))
Collecting mysqlclient==1.3.7 (from -r requirements.txt (line 52))
Collecting ndg-httpsclient==0.4.0 (from -r requirements.txt (line 53))
Collecting netaddr==0.7.18 (from -r requirements.txt (line 54))
  Using cached netaddr-0.7.18-py2.py3-none-any.whl
Collecting netifaces==0.10.5 (from -r requirements.txt (line 55))
Collecting openstacksdk==0.9.5 (from -r requirements.txt (line 56))
  Using cached openstacksdk-0.9.5-py2.py3-none-any.whl
Collecting os-client-config==1.21.1 (from -r requirements.txt (line 57))
  Using cached os_client_config-1.21.1-py2.py3-none-any.whl
Collecting osc-lib==1.1.0 (from -r requirements.txt (line 58))
  Using cached osc_lib-1.1.0-py2-none-any.whl
Collecting oslo.config==3.17.0 (from -r requirements.txt (line 59))
  Using cached oslo.config-3.17.0-py2.py3-none-any.whl
Collecting oslo.i18n==3.9.0 (from -r requirements.txt (line 60))
  Using cached oslo.i18n-3.9.0-py2.py3-none-any.whl
Collecting oslo.serialization==2.13.0 (from -r requirements.txt (line 61))
  Using cached oslo.serialization-2.13.0-py2.py3-none-any.whl
Collecting oslo.utils==3.16.0 (from -r requirements.txt (line 62))
  Using cached oslo.utils-3.16.0-py2.py3-none-any.whl
Collecting paramiko==1.16.0 (from -r requirements.txt (line 63))
  Using cached paramiko-1.16.0-py2.py3-none-any.whl
Collecting pbr==1.10.0 (from -r requirements.txt (line 64))
  Using cached pbr-1.10.0-py2.py3-none-any.whl
Collecting pep8==1.5.7 (from -r requirements.txt (line 65))
  Using cached pep8-1.5.7-py2.py3-none-any.whl
Collecting pexpect==4.0.1 (from -r requirements.txt (line 66))
Collecting pip==8.1.2 (from -r requirements.txt (line 67))
  Using cached pip-8.1.2-py2.py3-none-any.whl
Collecting pluggy==0.3.1 (from -r requirements.txt (line 68))
  Using cached pluggy-0.3.1-py2.py3-none-any.whl
Collecting positional==1.1.1 (from -r requirements.txt (line 69))
Collecting prettytable==0.7.2 (from -r requirements.txt (line 70))
Collecting psutil==4.1.0 (from -r requirements.txt (line 71))
Collecting ptyprocess==0.5.1 (from -r requirements.txt (line 72))
  Using cached ptyprocess-0.5.1-py2.py3-none-any.whl
Collecting py==1.4.31 (from -r requirements.txt (line 73))
  Using cached py-1.4.31-py2.py3-none-any.whl
Collecting pyasn1==0.1.9 (from -r requirements.txt (line 74))
  Using cached pyasn1-0.1.9-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r requirements.txt (line 75))
Collecting pycrypto==2.6.1 (from -r requirements.txt (line 76))
Collecting pyflakes==0.8.1 (from -r requirements.txt (line 77))
  Using cached pyflakes-0.8.1-py2.py3-none-any.whl
Collecting Pygments==2.1.3 (from -r requirements.txt (line 78))
  Using cached Pygments-2.1.3-py2.py3-none-any.whl
Collecting pyOpenSSL==0.15.1 (from -r requirements.txt (line 79))
  Using cached pyOpenSSL-0.15.1-py2.py3-none-any.whl
Collecting pyparsing==2.1.8 (from -r requirements.txt (line 80))
  Using cached pyparsing-2.1.8-py2.py3-none-any.whl
Collecting pyrsistent==0.11.12 (from -r requirements.txt (line 81))
Collecting pytest==2.9.0 (from -r requirements.txt (line 82))
  Using cached pytest-2.9.0-py2.py3-none-any.whl
Collecting pytest-capturelog==0.7 (from -r requirements.txt (line 83))
Collecting python-cinderclient==1.9.0 (from -r requirements.txt (line 84))
  Using cached python_cinderclient-1.9.0-py2.py3-none-any.whl
Collecting python-dateutil==2.5.3 (from -r requirements.txt (line 85))
  Using cached python_dateutil-2.5.3-py2.py3-none-any.whl
Collecting python-glanceclient==2.5.0 (from -r requirements.txt (line 86))
  Using cached python_glanceclient-2.5.0-py2.py3-none-any.whl
Collecting python-keystoneclient==3.5.0 (from -r requirements.txt (line 87))
  Using cached python_keystoneclient-3.5.0-py2.py3-none-any.whl
Collecting python-mimeparse==1.5.1 (from -r requirements.txt (line 88))
Collecting python-neutronclient==4.1.1 (from -r requirements.txt (line 89))
  Using cached python_neutronclient-4.1.1-py2.py3-none-any.whl
Collecting python-novaclient==6.0.0 (from -r requirements.txt (line 90))
  Using cached python_novaclient-6.0.0-py2.py3-none-any.whl
Collecting python-openstackclient==3.2.0 (from -r requirements.txt (line 91))
  Using cached python_openstackclient-3.2.0-py2.py3-none-any.whl
Collecting python-redmine==1.5.0 (from -r requirements.txt (line 92))
  Using cached python_redmine-1.5.0-py2.py3-none-any.whl
Collecting python-subunit==1.2.0 (from -r requirements.txt (line 93))
  Using cached python_subunit-1.2.0-py2.py3-none-any.whl
Collecting pytz==2016.6.1 (from -r requirements.txt (line 94))
  Using cached pytz-2016.6.1-py2.py3-none-any.whl
Collecting PyYAML==3.12 (from -r requirements.txt (line 95))
Collecting raven==5.11.1 (from -r requirements.txt (line 96))
  Using cached raven-5.11.1-py2.py3-none-any.whl
Collecting requests==2.11.1 (from -r requirements.txt (line 97))
  Using cached requests-2.11.1-py2.py3-none-any.whl
Collecting requestsexceptions==1.1.3 (from -r requirements.txt (line 98))
  Using cached requestsexceptions-1.1.3-py2.py3-none-any.whl
Collecting setuptools==20.3.1 (from -r requirements.txt (line 99))
  Using cached setuptools-20.3.1-py2.py3-none-any.whl
Collecting simplejson==3.8.2 (from -r requirements.txt (line 100))
Requirement already satisfied: six==1.10.0 in ./virtualenv/lib/python2.7/site-packages (from -r requirements.txt (line 101))
Collecting smmap==0.9.0 (from -r requirements.txt (line 102))
Collecting snowballstemmer==1.2.1 (from -r requirements.txt (line 103))
  Using cached snowballstemmer-1.2.1-py2.py3-none-any.whl
Collecting Sphinx==1.3.6 (from -r requirements.txt (line 104))
  Using cached Sphinx-1.3.6-py2.py3-none-any.whl
Collecting sphinx-rtd-theme==0.1.9 (from -r requirements.txt (line 105))
  Using cached sphinx_rtd_theme-0.1.9-py2-none-any.whl
Collecting stevedore==1.17.1 (from -r requirements.txt (line 106))
  Using cached stevedore-1.17.1-py2.py3-none-any.whl
Collecting testrepository==0.0.20 (from -r requirements.txt (line 107))
Collecting testtools==2.0.0 (from -r requirements.txt (line 108))
  Using cached testtools-2.0.0-py2.py3-none-any.whl
Collecting tox==2.3.1 (from -r requirements.txt (line 109))
  Using cached tox-2.3.1-py2.py3-none-any.whl
Collecting traceback2==1.4.0 (from -r requirements.txt (line 110))
  Using cached traceback2-1.4.0-py2.py3-none-any.whl
Collecting unicodecsv==0.14.1 (from -r requirements.txt (line 111))
Collecting unittest2==1.1.0 (from -r requirements.txt (line 112))
  Using cached unittest2-1.1.0-py2.py3-none-any.whl
Collecting virtualenv==15.0.1 (from -r requirements.txt (line 113))
  Using cached virtualenv-15.0.1-py2.py3-none-any.whl
Collecting warlock==1.2.0 (from -r requirements.txt (line 114))
Collecting web.py==0.37 (from -r requirements.txt (line 115))
Collecting wrapt==1.10.8 (from -r requirements.txt (line 116))
Collecting rfc3986>=0.2.0 (from oslo.config==3.17.0->-r requirements.txt (line 59))
  Using cached rfc3986-0.4.1-py2.py3-none-any.whl
Requirement already satisfied: argparse in /usr/lib/python2.7 (from unittest2==1.1.0->-r requirements.txt (line 112))
Installing collected packages: alabaster, MarkupSafe, Jinja2, PyYAML, pycrypto, ecdsa, paramiko, setuptools, ansible, pytz, Babel, beanstalkc, boto, bunch, pycparser, cffi, prettytable, pbr, unicodecsv, pyparsing, cmd2, stevedore, cliff, configobj, configparser, contextlib2, coverage, idna, ipaddress, enum34, pyasn1, cryptography, d2to1, wrapt, funcsigs, debtcollector, discover, docopt, docutils, extras, linecache2, traceback2, python-mimeparse, pyrsistent, unittest2, testtools, fixtures, mccabe, pep8, pyflakes, flake8, functools32, greenlet, gevent, smmap, gitdb, requests, GitPython, github2gitlab, githubpy, hacking, httplib2, iso8601, jsonpointer, jsonpatch, jsonschema, positional, keystoneauth1, mock, monotonic, msgpack-python, MySQL-python, mysqlclient, pyOpenSSL, ndg-httpsclient, netaddr, netifaces, requestsexceptions, os-client-config, openstacksdk, oslo.i18n, oslo.utils, simplejson, osc-lib, rfc3986, oslo.config, oslo.serialization, ptyprocess, pexpect, pip, pluggy, psutil, py, Pygments, pytest, pytest-capturelog, python-cinderclient, python-dateutil, python-keystoneclient, warlock, python-glanceclient, python-neutronclient, python-novaclient, python-openstackclient, python-redmine, python-subunit, raven, snowballstemmer, sphinx-rtd-theme, Sphinx, testrepository, virtualenv, tox, web.py
  Found existing installation: setuptools 34.2.0
    Uninstalling setuptools-34.2.0:
      Successfully uninstalled setuptools-34.2.0
  Found existing installation: pyparsing 2.1.10
    Uninstalling pyparsing-2.1.10:
      Successfully uninstalled pyparsing-2.1.10
  Found existing installation: pip 9.0.1
    Uninstalling pip-9.0.1:
      Successfully uninstalled pip-9.0.1
Successfully installed Babel-2.3.4 GitPython-1.0.2 Jinja2-2.8 MarkupSafe-0.23 MySQL-python-1.2.3 PyYAML-3.12 Pygments-2.1.3 Sphinx-1.3.6 alabaster-0.7.7 ansible-2.1.1.0 beanstalkc-0.4.0 boto-2.39.0 bunch-1.0.1 cffi-1.5.2 cliff-2.2.0 cmd2-0.6.8 configobj-5.0.6 configparser-3.3.0.post2 contextlib2-0.5.1 coverage-4.0.3 cryptography-1.3 d2to1-0.2.12.post1 debtcollector-1.8.0 discover-0.4.0 docopt-0.6.2 docutils-0.12 ecdsa-0.13 enum34-1.1.2 extras-0.0.3 fixtures-1.4.0 flake8-2.2.4 funcsigs-1.0.2 functools32-3.2.3.post2 gevent-1.0.2 gitdb-0.6.4 github2gitlab-1.5.5 githubpy-1.1.0 greenlet-0.4.9 hacking-0.10.2 httplib2-0.9.2 idna-2.0 ipaddress-1.0.16 iso8601-0.1.11 jsonpatch-1.14 jsonpointer-1.10 jsonschema-2.5.1 keystoneauth1-2.12.1 linecache2-1.0.0 mccabe-0.2.1 mock-1.3.0 monotonic-1.2 msgpack-python-0.4.8 mysqlclient-1.3.7 ndg-httpsclient-0.4.0 netaddr-0.7.18 netifaces-0.10.5 openstacksdk-0.9.5 os-client-config-1.21.1 osc-lib-1.1.0 oslo.config-3.17.0 oslo.i18n-3.9.0 oslo.serialization-2.13.0 oslo.utils-3.16.0 paramiko-1.16.0 pbr-1.10.0 pep8-1.5.7 pexpect-4.0.1 pip-8.1.2 pluggy-0.3.1 positional-1.1.1 prettytable-0.7.2 psutil-4.1.0 ptyprocess-0.5.1 py-1.4.31 pyOpenSSL-0.15.1 pyasn1-0.1.9 pycparser-2.14 pycrypto-2.6.1 pyflakes-0.8.1 pyparsing-2.1.8 pyrsistent-0.11.12 pytest-2.9.0 pytest-capturelog-0.7 python-cinderclient-1.9.0 python-dateutil-2.5.3 python-glanceclient-2.5.0 python-keystoneclient-3.5.0 python-mimeparse-1.5.1 python-neutronclient-4.1.1 python-novaclient-6.0.0 python-openstackclient-3.2.0 python-redmine-1.5.0 python-subunit-1.2.0 pytz-2016.6.1 raven-5.11.1 requests-2.11.1 requestsexceptions-1.1.3 rfc3986-0.4.1 setuptools-20.3.1 simplejson-3.8.2 smmap-0.9.0 snowballstemmer-1.2.1 sphinx-rtd-theme-0.1.9 stevedore-1.17.1 testrepository-0.0.20 testtools-2.0.0 tox-2.3.1 traceback2-1.4.0 unicodecsv-0.14.1 unittest2-1.1.0 virtualenv-15.0.1 warlock-1.2.0 web.py-0.37 wrapt-1.10.8
You are using pip version 8.1.2, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
++ pip install -e teuthology
Obtaining file:///home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/teuthology
Requirement already satisfied (use --upgrade to upgrade): setuptools in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): gevent in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): MySQL-python==1.2.3 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): PyYAML in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): argparse>=1.2.1 in /usr/lib/python2.7 (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): beanstalkc>=0.2.0 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): boto>=2.0b4 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): bunch>=1.0.0 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): configobj in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): six>=1.9 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): httplib2 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): paramiko>=1.15.1 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pexpect in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): requests in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): raven in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): web.py in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): docopt in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): psutil>=2.1.0 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): configparser in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pytest in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pytest-capturelog in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): mock in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Collecting fudge (from teuthology==1.0.0)
  Using cached fudge-1.1.0.tar.gz
Requirement already satisfied (use --upgrade to upgrade): ansible>=2.0 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pyopenssl>=0.13 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): ndg-httpsclient in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pyasn1 in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): prettytable in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): python-dateutil in ./virtualenv/lib/python2.7/site-packages (from teuthology==1.0.0)
Collecting manhole (from teuthology==1.0.0)
  Using cached manhole-1.3.0-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): greenlet>=0.4.7 in ./virtualenv/lib/python2.7/site-packages (from gevent->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pycrypto!=2.4,>=2.1 in ./virtualenv/lib/python2.7/site-packages (from paramiko>=1.15.1->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): ecdsa>=0.11 in ./virtualenv/lib/python2.7/site-packages (from paramiko>=1.15.1->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): ptyprocess>=0.5 in ./virtualenv/lib/python2.7/site-packages (from pexpect->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): contextlib2 in ./virtualenv/lib/python2.7/site-packages (from raven->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): py>=1.4.29 in ./virtualenv/lib/python2.7/site-packages (from pytest->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): funcsigs; python_version < "3.3" in ./virtualenv/lib/python2.7/site-packages (from mock->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pbr>=0.11 in ./virtualenv/lib/python2.7/site-packages (from mock->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): jinja2 in ./virtualenv/lib/python2.7/site-packages (from ansible>=2.0->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): cryptography>=0.7 in ./virtualenv/lib/python2.7/site-packages (from pyopenssl>=0.13->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe in ./virtualenv/lib/python2.7/site-packages (from jinja2->ansible>=2.0->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): idna>=2.0 in ./virtualenv/lib/python2.7/site-packages (from cryptography>=0.7->pyopenssl>=0.13->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): ipaddress in ./virtualenv/lib/python2.7/site-packages (from cryptography>=0.7->pyopenssl>=0.13->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): enum34 in ./virtualenv/lib/python2.7/site-packages (from cryptography>=0.7->pyopenssl>=0.13->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): cffi>=1.4.1 in ./virtualenv/lib/python2.7/site-packages (from cryptography>=0.7->pyopenssl>=0.13->teuthology==1.0.0)
Requirement already satisfied (use --upgrade to upgrade): pycparser in ./virtualenv/lib/python2.7/site-packages (from cffi>=1.4.1->cryptography>=0.7->pyopenssl>=0.13->teuthology==1.0.0)
Installing collected packages: fudge, manhole, teuthology
  Running setup.py install for fudge: started
    Running setup.py install for fudge: finished with status 'done'
  Running setup.py develop for teuthology
Successfully installed fudge-1.1.0 manhole-1.3.0 teuthology
You are using pip version 8.1.2, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
++ pip install -e .
Obtaining file:///home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench
    Complete output from command python setup.py egg_info:
    [pbr] Generating ChangeLog
    setup hook pbr.hooks.setup_hook raised exception: git history requires a target version of pbr.version.SemanticVersion(1.5.18), but target version is pbr.version.SemanticVersion(1.5.17)
    
    Traceback (most recent call last):
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/d2to1/util.py", line 182, in cfg_to_args
        hook_fn(config)
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/hooks/__init__.py", line 25, in setup_hook
        metadata_config.run()
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/hooks/base.py", line 27, in run
        self.hook()
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/hooks/metadata.py", line 26, in hook
        self.config['name'], self.config.get('version', None))
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/packaging.py", line 716, in get_version
        version = _get_version_from_git(pre_version)
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/packaging.py", line 656, in _get_version_from_git
        result = _get_version_from_git_target(git_dir, target_version)
      File "/home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/virtualenv/local/lib/python2.7/site-packages/pbr/packaging.py", line 618, in _get_version_from_git_target
        dict(new=new_version, target=target_version))
    ValueError: git history requires a target version of pbr.version.SemanticVersion(1.5.18), but target version is pbr.version.SemanticVersion(1.5.17)
    
    error in setup command: Error parsing /home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/setup.cfg: SystemExit: 1
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /home/gitlab-runner/builds/9120dac4/0/root/ceph-workbench/
You are using pip version 8.1.2, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
+ bash tests/teardown.sh
Failed to stop container (test-gitlab): Error response from daemon: No such container: test-gitlab
Failed to remove container (test-gitlab): Error response from daemon: No such container: test-gitlab
Failed to stop container (gitlab-postgresql): Error response from daemon: No such container: gitlab-postgresql
Failed to remove container (gitlab-postgresql): Error response from daemon: No such container: gitlab-postgresql
Failed to stop container (test-redis): Error response from daemon: No such container: test-redis
Failed to remove container (test-redis): Error response from daemon: No such container: test-redis
Failed to stop container (redmine): Error response from daemon: No such container: redmine
Failed to remove container (redmine): Error response from daemon: No such container: redmine
Failed to stop container (postgresql-redmine): Error response from daemon: No such container: postgresql-redmine
Failed to remove container (postgresql-redmine): Error response from daemon: No such container: postgresql-redmine

ERROR: Build failed with: exit status 1

Build #527

Duration: 3 minutes 48 seconds

Created:

Finished:

Runner: #1

Commit

Branch: master

Author: Loic Dachary

Message: Merge branch 'wip-suse-master' into 'master' requirements.txt: drop libvirt-python Signed-off-by: Nathan Cutler <ncutler@suse.com> See merge request !53